[Snort-users] problems with barnyard, snort and mysql

Alejandro Flores alejandrorflores at ...11827...
Sun Mar 13 05:36:56 EST 2005


Hey,

Hmm I believe that barnyard has no support for mysql 4. You'll have to
install also the mysql-shared-compat rpm.

Regards,
Alejandro Flores


On Sat, 12 Mar 2005 10:12:41 -0500, Kevin Smith <kjsmith at ...13166...> wrote:
>  Okay, I did notice I forgot to install dev files for mysql, once I did that
> I ran ./configure --enable-mysql, however then it error or the library
> files. 
>  
>  checking for /usr/include/mysql/mysql.h... yes
>  checking for mysql_real_connect in -lmysqlclient... no
>  **********************************************
>    ERROR: unable to find mysqlclient library
>    checked in the following places
>          /usr/lib/
>  **********************************************
>  
>  however, in /usr/lib there are these files 
>  
>  /usr/lib/libmysqlclient.a
>  /usr/lib/libmysqlclient.la
>  /usr/lib/libmysqlclient_r.a
>  /usr/lib/libmysqlclient_r.la
>  /usr/lib/libmysqlclient_r.so
>  /usr/lib/libmysqlclient_r.so.10
>  /usr/lib/libmysqlclient_r.so.10.0.0
>  /usr/lib/libmysqlclient_r.so.12
>  /usr/lib/libmysqlclient_r.so.12.0.0
>  /usr/lib/libmysqlclient_r.so.14
>  /usr/lib/libmysqlclient_r.so.14.0.0
>  /usr/lib/libmysqlclient.so
>  /usr/lib/libmysqlclient.so.10
>  /usr/lib/libmysqlclient.so.10.0.0
>  /usr/lib/libmysqlclient.so.12
>  /usr/lib/libmysqlclient.so.12.0.0
>  /usr/lib/libmysqlclient.so.14
>  /usr/lib/libmysqlclient.so.14.0.0
>  
>  I know some of them probably are not needed but I think they were left
> there from upgrading the database. One of these should be the file it needs
> correct? Should I just remove anything that is below 14? Since 14 is in
> reference to MySQL version 4.1 which is what the server is running. Or are
> these not even the files I need?
>  
>  Thanks again,
>  
>  Kevin




More information about the Snort-users mailing list