[Snort-users] libpcap help

Sean Brown sblinux at ...9344...
Wed Sep 22 09:07:19 EDT 2004


On September 22, 2004 9:16 am, ebenoit at ...12465... wrote:
> Running compiled libpcap.0.8.3 from tcpdump.org
> I tried to install -i snort-2.1.3-1.i386.rpm
>
> I get the follow error: libpcap.so.0.6.2 is needed by snort-2.1.3-1
>
> is there any way around using an old version of libpcap??  I like the rpm
> and noticed that the tar file for snort has the same instructions in it
> "make sure you have --libpcap.so.0.6.2-- running"
>
This is an rpm dependency problem, rpm doesn't know you have libpcap on your 
system because you compiled it yourself. Either install the snort rpm without 
dependency checking (inadvisable), or installing a libpcap rpm (better), or 
build snort from source. That last one might be the better idea if your not 
going to be installing other rpms that depend on snort.

It's generally a bad idea to build libraries yourself on a system that does 
dependency checking, since your usually installing a library to satisfy a 
requirement of another app, and a built library makes no entry in the rpm 
database so rpm has no clue it exists.

-Sean Brown




More information about the Snort-users mailing list