[Snort-users] I am using Petrick harper's guide still have problems !!

Paul Martin pmartin at ...11611...
Mon Sep 13 06:30:05 EDT 2004


See, this is why I like Gentoo.  It does the dependency thing for you.  =)

But I digress.

Seeing something like this -

[root at ...12378... snortinstall]# rpm -ivh

libmysqlclient12-4.0.20-67426cl.i386.rpm 
error: Failed dependencies:
        libcrypto.so.0.9.7 is needed by libmysqlclient12-4.0.20-67426cl
        libssl.so.0.9.7 is needed by libmysqlclient12-4.0.20-67426

- would make me think that you need to install the libssl and the libcrypto RPMs.  Make sure to get the right versions.

Paul Martin
Network Technician
Hilton Grand Vacations Co.
(407) 393-3034
pmartin at ...11611...



Juan Fernandez wrote:

>Hi !
>
>I us fedora core 1 (now I am trying to install the sensor from the guide of
>Patrick harper) .
>
>When I try to install snort-mysql-2.1.3-0.fdr.1.i386.rpm I receive the next:
>
>[root at ...12378... snortinstall]# rpm -ivh
>snort-mysql-2.1.3-0.fdr.1.i386.rpm
>error: Failed dependencies:
>        libmysqlclient.so.10 is needed by snort-mysql-2.1.3-0.fdr.1
>[root at ...12378... snortinstall]# find / -name libmysqlclient.so.10
>/usr/local/mysql/lib/mysql/libmysqlclient.so.10
>/snortinstall/mysql-3.23.52/libmysql/.libs/libmysqlclient.so.10
>
>I also tried to download and install
>libmysqlclient12-4.0.20-67426cl.i386.rpm and this is what I recieved:
>
>[root at ...12378... snortinstall]# rpm -ivh
>libmysqlclient12-4.0.20-67426cl.i386.rpm 
>error: Failed dependencies:
>        libcrypto.so.0.9.7 is needed by libmysqlclient12-4.0.20-67426cl
>        libssl.so.0.9.7 is needed by libmysqlclient12-4.0.20-67426
>
>Do I need to download crypto52 and install? the depandencies in really a
>nightmare  !!!
>
>Thanks !!
>  
>
*snip*




More information about the Snort-users mailing list