[Snort-users] problems installing Barnyard on obsd 3.4

Dirk Geschke Dirk_Geschke at ...1344...
Mon Nov 22 00:17:01 EST 2004


Hi Russel,

> 	I am trying to install barnyard on a obsd system but configure exits
> complaining it can't find the mysql client library.
> 
> configure command:
> ./configure --enable-mysql --with-mysql-libraries=/usr/local/lib/
> 
> I verified that I had specified the correct dir in the parameters to
> ./configure and then checked the config.log file where I found this:
> 
> configure:2559: checking for mysql_real_connect in -lmysqlclient
> configure:2578: gcc -o conftest -g -O2 -Wall -I/usr/local/include/mysql 
> -DENABLE_MYSQL  -L/usr/local/lib/ conftest.c -lmysqlclient   -lz -lssl
> -lmysqlclient 1>&5
> /usr/lib/libssl.so.8.0: undefined reference to `BIO_find_type'
> /usr/lib/libssl.so.8.0: undefined reference to `EVP_enc_null'
> /usr/lib/libssl.so.8.0: undefined reference to `EVP_CIPHER_CTX_init'
> /usr/lib/libssl.so.8.0: undefined reference to `X509_NAME_dup'
> /usr/lib/libssl.so.8.0: undefined reference to `COMP_compress_block'
> /usr/lib/libssl.so.8.0: undefined reference to `EVP_rc2_cbc'
> /usr/lib/libssl.so.8.0: undefined reference to `sk_new_null'
> /usr/lib/libssl.so.8.0: undefined reference to

this sounds like you are including the wrong ssl headers. Maybe
you installed two differnt versions of libssl. OpenSSL changes the
API of the library with nearly every new version. To be compatible
with older code they map this via the header files. The result is
what you see if the header files do not match the version of the
library.

Maybe you installed a newer version of libssl but you are still
using an older version of MySQL which was linked dynamically against
an older library?

Best regards

Dirk





More information about the Snort-users mailing list