[Snort-users] perl preprocessor plugin?

Cliff Massey cliff at ...12677...
Thu Nov 18 16:11:08 EST 2004


I tried to apply the patch to 2.2.0, but it failed. What is the latest 
version of snort that this works with currently?

Could you please update this to work with the most recent version? It 
would be much appreciated.

  Cliff


On Nov 18, 2004, at 12:46 PM, Brian wrote:

> On Thu, Nov 18, 2004 at 12:07:30PM -0800, Cliff Massey wrote:
>> There used to be a perl preprocessor for snort called snort-perl.
>> Has this been discontinued? Does anyone know if there is a way to
>> use a perl script as a preprocessor? This would be very useful.
>
> snort-perl was never a preprocessor. snort-perl is a detection plugin
> only ever available as a patch.
>
> Jeff & I wrote it a few years ago.  It is a little out of date, but
> still useful.
>
> I'm currently working on a replacement for it that is much more
> advanced, but don't expect to see my replacement for another few
> months.  If you ask very nicely, I'll update snort-perl to work with
> 2.3.0RC1 (which should be out shortly).
>
> Brian
>





More information about the Snort-users mailing list