[Snort-users] Problem compiling snort + mysql

Shawn Kottke skottke at ...11993...
Thu Nov 4 10:21:29 EST 2004


Here are a couple of things that may help:

1. when compiling snort use the command like:
./configure --with-mysql=/usr/local/mysql

2. I read somewhere in the snort archives that if you are using a
version of mysql that is newer than 4.0.18 (or something close) zlib is
no longer compiled in to the binaries and you must compile mysql to get
zlib compiled in. Use this command (or one like it) in your mysql source
directory:
./configure --prefix=/usr/local/mysql --with-zlib

I have used version 4.0.20 of mysql and have needed to compile the
source as such to get it to work.

I hope this helps.
Shawn

-----Original Message-----
From: snort-users-admin at lists.sourceforge.net
[mailto:snort-users-admin at lists.sourceforge.net] On Behalf Of
ml at ...12631...
Sent: Thursday, November 04, 2004 9:46 AM
To: snort-users at lists.sourceforge.net
Subject: [Snort-users] Problem compiling snort + mysql

Hi,

os: Mandrake 10
snort: snort-2.2.0
mysql: mysql-4.1.7

I did search the archive but none of the answers I've found helped to
fix my problem.

I want to compile snort --with-mysql

my mysql 4.1.7 sources are in /root/mysql-4.1.7 and mysql is installed
in
/usr/local/mysql

I did ./configure --with-mysql=/root/mysql-4.1.7 

I do see that configure finds mysql libraries:

checking for mysql... yes

Upon compiling I get the following error message:

/usr/lib/mysql/libmysqlclient.a(my_compress.o)(.text+0xbc): In function
`my_compress_alloc':
: undefined reference to `compress'
/usr/lib/mysql/libmysqlclient.a(my_compress.o)(.text+0x13a): In function
`my_uncompress':
: undefined reference to `uncompress'hints
collect2: ld returned 1 exit status
make[3]: *** [snort] Error 1
make[3]: Leaving directory `/root/snort-2.2.0/src'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/root/snort-2.2.0/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/snort-2.2.0'
make: *** [all] Error 2


I added LDFLAGS = "-lz" before running configure but no luck. Still same
error
message.

I've figured maybe maybe something in the source is not right so I've
installed
mysql libraries from the RPM package. Same outcome when compiling.

Any pointers and tips are appreciated.




-------------------------------------------------------
This SF.Net email is sponsored by:
Sybase ASE Linux Express Edition - download now for FREE
LinuxWorld Reader's Choice Award Winner for best database on Linux.
http://ads.osdn.com/?ad_idU88&alloc_id065&op=ick
_______________________________________________
Snort-users mailing list
Snort-users at lists.sourceforge.net
Go to this URL to change user options or unsubscribe:
https://lists.sourceforge.net/lists/listinfo/snort-users
Snort-users list archive:
http://www.geocrawler.com/redir-sf.php3?list=ort-users




More information about the Snort-users mailing list