[Snort-users] Libnet 1.0.2a with Libnet 1.1.x

Joshua Berry jberry at ...11848...
Fri May 21 14:12:03 EDT 2004


Has anyone been able to get Snort 2.1.x working on a system with both of
these libraries?  I have to use Libnet 1.1.x for another application so
I have installed Libnet 1.0.2a to /usr/src/libnet.
 
I run ./configure -enable-flexresp
-with-libnet-includes=/usr/src/libnet/include
-with-libnet-libraries=/usr/src/libnet/lib
 
And it fails with this error:
 
............................................
checking libnet.h usability... yes
checking libnet.h presence... yes
checking for libnet.h... yes
checking for libnet version 1.0.2a... yes
checking for libnet_build_ip in -lnet... no
 
   ERROR!  Libnet library not found, go get it from
   http://www.packetfactory.net/projects/libnet/
   or use the --with-libnet-* options, if you have it installed
   in unusual place
#
 
 
Josh Berry, CISSP & MCSE 
Information Security 
-------------------------------------------------------------------- 
If you spend more on coffee than on IT security, you will be hacked. 
What's more, you deserve to be hacked. 
     -- (Former) White House Cybersecurity adviser Richard Clarke 
 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.snort.org/pipermail/snort-users/attachments/20040521/3431d7ca/attachment.html>


More information about the Snort-users mailing list