[Snort-users] Re: same problem as you

Dirk Geschke Dirk at ...10648...
Mon May 10 06:53:04 EDT 2004


Hi Snorty,

> Since last time I failed - same of everything, I
> havent tried, and havent seen any message about why
> we can't do it. 
> 
> Please, anyone, if you know why we can not upgrade to
> 2.1.1 from 2.0.6 snort on Solaris 8, do let us know,
> even some intelligent guessing would help. 

the error messges explains it at all:

> > #/snort/snort-2.1.1# snort -V
> > ld.so.1: snort: fatal: libpcre.so.0: open failed: No
> > such file or directory
> > Killed
> > Can you share some idea where might have gone wrong
> > please?
> > I have libpcre.so.0 under /usr/local/lib, and
> > /usr/local/bin, could it be a version issue?

The dynmic linker does not find the needed library.
On Solaris the /usr/local/lib path is not searched
for dynamic libraries by default.

Use either the linker flag -R:/usr/local/lib
or set the LD_LIBRARY_PATH to /usr/local/lib and
restart snort again. You can set this variable also
on the command line:

LD_LIBRARY_PATH=/usr/local/lib snort -V

or you can use LD_PRELOAD to preload the needed library.

Best regards

Dirk




More information about the Snort-users mailing list