[Snort-users] Re: [Barnyard-users] Typical barnyard compile problems (mysql error)

Andreas andreas at ...1574...
Wed May 5 12:30:13 EDT 2004


On Wed, May 05, 2004 at 09:22:59PM +0200, Thomas Bechtold wrote:
> Right, that works. thanks Bammkkkk!
> 
> now a short summary:
> 
> - delete the string " -lz -lssl" from "configure.in" in 
> barnyard-0.2.0-directory.

Newer mysql build might have ssl support. The correct way to fix this
would be to make barnyard use the mysql .la file which would state if
-lssl is necessary or not.

In my case, for example:

[andreas at ...5834... andreas]$ cat /usr/lib/libmysqlclient.la |grep dependency_libs
dependency_libs=' -lz -lcrypt -lnsl -lm -L/usr/lib -lssl -lcrypto'





More information about the Snort-users mailing list