[Snort-users] Can't seem to compile with --enable-flexresp on RedHat 9

Matt Kettler mkettler at ...4108...
Thu Jul 15 12:09:15 EDT 2004


At 01:08 PM 7/15/2004, Rhugga wrote:
>When I add the --enable-flexresp option to configure it dies with this error:
>
>checking for libnet.h... yes
>checking for libnet version 1.0.2a... ./configure: line 1: libnet-config: 
>command not found
>
>**********************************************
>   ERROR: unable to find libnet 1.0.2a (libnet.h)
>   checked in the following places
>**********************************************
>
>Do I need the an older libnet, or am I missing part of the package or 
>what? I installed the libnet-1.1.0-fr2.i386.rpm for Red Hat 9.

Currently flexresp works with libnet 1.0.2a, only. It doesn't work with 
newer, or older versions.

The config file in 2.2.0-RC1 is much more explicit about this than the 
older released versions:

       echo "   ERROR!  Snort with --enable-flexresp will *only* work with"
       echo "   libnet version 1.0.2a, go get it from"
       echo "   http://www.packetfactory.net/projects/libnet/"





More information about the Snort-users mailing list