[Snort-users] Can't seem to compile with --enable-flexresp on RedHat 9

Joshua Berry jberry at ...11848...
Thu Jul 15 10:57:06 EDT 2004


Yes, looks like you have installed a newer version of libnet.  Snort
only works with libnet 1.0.2a

-----Original Message-----
From: snort-users-admin at lists.sourceforge.net
[mailto:snort-users-admin at lists.sourceforge.net] On Behalf Of Rhugga
Sent: Thursday, July 15, 2004 12:09 PM
To: Snort-User Mailing List
Subject: [Snort-users] Can't seem to compile with --enable-flexresp on
RedHat 9


When I add the --enable-flexresp option to configure it dies with this 
error:

checking for libnet.h... yes
checking for libnet version 1.0.2a... ./configure: line 1: 
libnet-config: command not found

**********************************************
  ERROR: unable to find libnet 1.0.2a (libnet.h)
  checked in the following places
**********************************************

Do I need the an older libnet, or am I missing part of the package or 
what? I installed the libnet-1.1.0-fr2.i386.rpm for Red Hat 9.

Here is my build process: (I always start each new configuration with a 
freshly unpacked tarball for sanity sake)

export LDFLAGS="-L/usr/lib"
export CPPFLAGS="-I/usr/include"
syslog:/usr/local/src/snort-2.1.3 #./configure 
--prefix=/usr/local/snort-2.1.3 --enable-perfmonitor 
--enable-linux-smp-stats  --enable-flexresp
--with-mysql=/usr/local/mysql

-Chuck



-------------------------------------------------------
This SF.Net email is sponsored by BEA Weblogic Workshop
FREE Java Enterprise J2EE developer tools!
Get your free copy of BEA WebLogic Workshop 8.1 today.
http://ads.osdn.com/?ad_id=4721&alloc_id=10040&op=click
_______________________________________________
Snort-users mailing list
Snort-users at lists.sourceforge.net
Go to this URL to change user options or unsubscribe:
https://lists.sourceforge.net/lists/listinfo/snort-users
Snort-users list archive:
http://www.geocrawler.com/redir-sf.php3?list=snort-users




More information about the Snort-users mailing list