[Snort-users] Installing Snort on a Red Hat 8 or 9

Steve Loughran stevelml1 at ...1465...
Fri Jul 2 08:03:08 EDT 2004


Alberto

You are not looking carefully... you are greping for "libcap" but you need
to be looking for "libpcap" (spot the extra "p" in the middle)... libcap is
not the same as lib*P*cap

Steve


----- Original Message ----- 
From: "Alberto García Gómez" <alberto at ...12058...>
To: "Joshua Berry" <jberry at ...11848...>; "Nick Oliver"
<nwoliver at ...4250...>; <snort-users at lists.sourceforge.net>
Sent: Friday, July 02, 2004 9:23 AM
Subject: Re: [Snort-users] Installing Snort on a Red Hat 8 or 9


Maybe u don't read the entire message, check it out again and u'll see that
I make this step already and the ver differs. indeed the ver thats snort
requieres is lower than I have installed(by defaut) in my system

;-)
  ----- Original Message ----- 
  From: Joshua Berry
  To: Alberto García Gómez ; Nick Oliver ; snort-users at lists.sourceforge.net
  Sent: Friday, July 02, 2004 3:45 PM
  Subject: RE: [Snort-users] Installing Snort on a Red Hat 8 or 9


  You are grepping for libcap, what you need is libpcap.  rpm -qa | grep
libpcap, see if that is installed.



  -----Original Message-----
  From: snort-users-admin at lists.sourceforge.net
[mailto:snort-users-admin at lists.sourceforge.net] On Behalf Of Alberto García
Gómez
  Sent: Friday, July 02, 2004 2:34 AM
  To: Nick Oliver; snort-users at lists.sourceforge.net
  Subject: Re: [Snort-users] Installing Snort on a Red Hat 8 or 9



  Check This



  checking for pcap_datalink in -lpcap... no



     ERROR!  Libpcap library/headers not found, go get it from
     http://www.tcpdump.org
     or use the --with-libpcap-* options, if you have it installed
     in unusual place

  this happen when I make a configure of snort



  and now check this



  # rpm -qa | grep libcap
  libcap-1.10-12



  I have installed(By system default) this ver of libcap, but snort is
asking me by a lower ver of it, and my question is How I can use my
installed version instead the lower that snort need?



  Even when I use the param --with-libpcap-includes
or --with-libpcap-libraries and I give it the path of the libraries the
error persist

    ----- Original Message ----- 

    From: Nick Oliver

    To: Alberto García Gómez ; snort-users at lists.sourceforge.net

    Sent: Friday, July 02, 2004 4:21 AM

    Subject: Re: [Snort-users] Installing Snort on a Red Hat 8 or 9




    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1



    If you would like a good, basic document from which to install Snort
    on a RH9 or Fedora Core 1 box, go to www.ntsug.com and download
    Patrick Harper's paper.  There are several versions there, one should
    fit your needs.  It is a paper that will require you to reload your
    machine, but will provide the correct information necessary to
    successfully install both RH9 and Snort.
    nwo
    - ----- Original Message ----- 
    From: Alberto García Gómez
    To: snort-users at lists.sourceforge.net
    Sent: Thursday, July 01, 2004 1:24 PM
    Subject: [Snort-users] Installing Snort on a Red Hat 8 or 9




    I'm trying to install the lastest version of snort on a red hat 8 and
    a red hat 9, and it's asking by libcap 0.6 but red hat 8 and 9
    install 1.0 by default, what I can do??



    -----BEGIN PGP SIGNATURE-----
    Version: PGP 8.0.2



    iQA/AwUBQOTGqoHa2qg1FTg0EQKS5wCggyrV2gt9YnkuQ+nAnEVdKLxyj3cAoJcj
    4VTMq2yAm6m0jcDDyiGjTolC
    =HlQS
    -----END PGP SIGNATURE-----






More information about the Snort-users mailing list