[Snort-users] Trouble compiling Snort-2.1.0: snprintf.c (fwd)

Tomasz Piotr Palarz tpalar1 at ...6828...
Sun Feb 15 17:10:01 EST 2004


Hi

I'm sending this again because I'm not sure if it went through the first
time. I got an email from some company about my mail not being sent. I'm
still having trouble compiling snort-2.1.0 with inline for Linux.

Tomasz Piotr Palarz
Computer Science Undergraduate
University of Illinois at Chicago


---------- Forwarded message ----------
Date: Sat, 14 Feb 2004 16:06:24 -0600 (CST)
From: Tomasz Piotr Palarz <tpalar1 at ...6828...>
To: snort-users at lists.sourceforge.net
Subject: [Snort-users] Trouble compiling Snort-2.1.0: snprintf.c

Hello all,

I'm having some trouble compiling snort 2.1.0 . I'm trying to set up a
Honeynet. My honeywall is running Red Hat 7.3. I've updated iptables to
1.2.9, patched the kernel and recompiled. I patched Snort 2.1.0 with the
snort_inline-2.1.0a patch. I'm trying to get this to work with mysql and
ACID.

I run ./configure --enable-inline=yes --with-mysql=/usr/local/mysql
--with-libnet-includes=/usr/include
--with-libnet-libraries=/usr/lib --with-lipipq-includes=/usr/local/include
--with-libipq-libraries=/usr/local/lib

I have Libnet 1.0.2a and whatever version of libipq came with iptables
1.2.9.

When I run make, it compiles a good deal of the way, but then I get an
error about snprintf. It looks like this:

make  all-recursive
make[1]: Entering directory `/root/snort-2.1.0'
Making all in src

... ... ...

gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../src -I../src/sfutil
-I/usr/include/pcap -I../src/output-plugins -I../src/detection-plugins
-I../src/preprocessors -I../src/preprocessors/flow
-I../src/preprocessors/portscan  -I../src/preprocessors/flow/int-snort
-I../src/preprocessors/HttpInspect/include  -I/usr/include/pcre
-I/usr/local/mysql/include -DENABLE_MYSQL -I/usr/local/include
-I/usr/include  -g -O2 -Wall -DGIDS -D_BSD_SOURCE -D__BSD_SOURCE
-D__FAVOR_BSD -DHAVE_NET_ETHERNET_H -DLIBNET_LIL_ENDIAN -c
`test -f snprintf.c || echo './'`snprintf.c
snprintf.c: In function `sm_dopr' :
snprintf.c:153: conflicting types for `sys_errlist'
/usr/include/stdio.h:554: previous declaration of `sys_errlist'
make[3]: *** [snprintf.o] Error 1
make[3]: Leaving directory `/root/snort-2.1.0/src'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/root/snort-2.1.0/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/snort-2.1.0'
make: *** [all] Error 2
[root at ...11211... snort-2.1.0]#

I saw in the archives about a month ago someone was having the same issue
with snort-1.9.0 on FreeBSD, but I didn't see a solution. Any help with
this would be greatly appreciated. Thanks in advance.

Tomek Piotr Palarz
Computer Science Undergraduate
University of Illinois at Chicago



-------------------------------------------------------
SF.Net is sponsored by: Speed Start Your Linux Apps Now.
Build and deploy apps & Web services for Linux with
a free DVD software kit from IBM. Click Now!
http://ads.osdn.com/?ad_id=1356&alloc_id=3438&op=click
_______________________________________________
Snort-users mailing list
Snort-users at lists.sourceforge.net
Go to this URL to change user options or unsubscribe:
https://lists.sourceforge.net/lists/listinfo/snort-users
Snort-users list archive:
http://www.geocrawler.com/redir-sf.php3?list=snort-users




More information about the Snort-users mailing list