[Snort-users] glibc dependency error with RH 7.3

Jose Maria Lopez jkerouac at ...12346...
Tue Aug 31 13:36:59 EDT 2004


El dom, 29 de 08 de 2004 a las 00:46, Andy Thiel escribió:
> Hi,
> I'm having problems installing snort, I'm getting glibc dependency errors.
> I running RedHat 7.3, trying to install snort-2.1.3-1.i386.rpm
> 
> I can't find a newer version of glibc other than 2.2.5 and really don't know
> what I'm doing anyway.
> 
> Am I having these problems because I'm running RH 7.3?
> 
> Should I be installing a different package?
> 
> [root at ...12350... snort]# rpm -ivh [root at ...12350... snort]# rpm -ivh
> snort-2.1.3-1.i386.rpm
> error: failed dependencies:
>         libc.so.6(GLIBC_2.3)   is needed by snort-2.1.3-1
> 
> totally new to this, hope you can help.
> 
> Thanks,
> Andy
> 

Maybe you can use alien to make a tar.gz package, uncompress it in
a directory and see if you can execute the snort executable with
your glibc. If you can then you can use --nodeps with rpm to install
the package. Or you can simply use the --nodeps and see if it works,
if it doesn't you can uninstall it.

The solution if the binary doesn't work could be to download the
source code and compile it. It's not difficult to do it and then
it would work with your glibc.


-- 
Jose Maria Lopez Hernandez
Director Tecnico de bgSEC
jkerouac at ...12346...
bgSEC Seguridad y Consultoria de Sistemas Informaticos
http://www.bgsec.com
ESPAÑA

The only people for me are the mad ones -- the ones who are mad to live,
mad to talk, mad to be saved, desirous of everything at the same time,
the ones who never yawn or say a commonplace thing, but burn, burn, burn
like fabulous yellow Roman candles.
                -- Jack Kerouac, "On the Road"





More information about the Snort-users mailing list