[Snort-users] error installing according to doc

Raymond Norton admin at ...10144...
Mon Sep 22 16:07:07 EDT 2003


I'm following the redhat 9 install doc, which by the way is done very well,
but I'm getting the following error when trying to do make install on php.





[root at ...2306... php-4.3.1]#
./configure --prefix=/www/php --with-apxs2=/www/bin/apxs --with-config-filep
ath=/www/php --enable-sockets --with-mysql=/usr/local/mysql --with-zlib-dir=
/usr/local --with-gd



make



make install



<error>


[root at ...2306... php-4.3.1]# make install

Installing PHP CLI binary: /www/php/bin/

Installing PHP SAPI module

/www/build/instdso.sh SH_LIBTOOL='/www/build/libtool' libphp4.la
/www/modules

/www/build/libtool --mode=install cp libphp4.la /www/modules/

cp .libs/libphp4.lai /www/modules/libphp4.la

cp .libs/libphp4.a /www/modules/libphp4.a

ranlib /www/modules/libphp4.a

chmod 644 /www/modules/libphp4.a

libtool: install: warning: remember to run `libtool --finish
/root/snort/php-4.3.1/libs'

Warning! dlname not found in /www/modules/libphp4.la.

Assuming installing a .so rather than a libtool archive.

chmod 755 /www/modules/libphp4.so

chmod: failed to get attributes of `/www/modules/libphp4.so': No such file
or directory

apxs:Error: Command failed with rc=65536



</error>



Thanks in advance



Raymond






More information about the Snort-users mailing list