[Snort-users] How to upgrade from Snort 1.9.1 to 2.0.1 Please....

Erek Adams erek at ...950...
Wed Sep 17 05:42:03 EDT 2003


On Tue, 16 Sep 2003, Snortty wrote:

> I'm running snort 1.9.1 on Solaris 8, it works fine,
> just reporting lots of errors when run it after
> downloading new rules.
>
> I plan to upgrade it to Snort 2.0.1, but want to make
> sure before going ahead - better having the old snort
> working than a newer one which is not.
>
> Do I have to remove snort 1.9.1 first and how to do it
> the right way? or just install the new one on top of
> the old one.
>
> I did which snort, it reports:
> # which snort
> /usr/local/bin/snort
> #
>
> I'm very new in this, so please advise.

Long story made short:  1.9.x is dead--No longer maintained.

Longer version:  The new rules are 2.x style.  They won't work with 1.9.x.
The upgrade is seamless.  Replace the executeable, snort.conf, *.rules,
*.map, *.config and you're ready to go.

If you need more info, drop me a line.

Cheers!

-----
Erek Adams

   "When things get weird, the weird turn pro."   H.S. Thompson




More information about the Snort-users mailing list