[Snort-users] Re: Apache for snort

shrek-m at ...348... shrek-m at ...348...
Fri May 9 05:58:08 EDT 2003


LAKHANI, AAMIR schrieb:
> Okay, I am still having some problems. I have gotten Apache and MySQL
> installed. I am trying to get php installed correctly and recieve the
> following:
> 
> [root at ...9123... php]# rpm -ivh php-4.2.2-8.0.7.i386.rpm
> warning: php-4.2.2-8.0.7.i386.rpm: V3 DSA signature: NOKEY, key ID db42a60e
> error: Failed dependencies:
>         libcrypto.so.2 is needed by php-4.2.2-8.0.7
>         libssl.so.2 is needed by php-4.2.2-8.0.7
> 
> Appears OpenSSL is not installed correctly. I downloaded the latest RPM and
> here is what I got:
> 
> [root at ...9123... download]# rpm -ivh openssl-0.9.7a-5.ia64.rpm
> warning: openssl-0.9.7a-5.ia64.rpm: V3 DSA signature: NOKEY, key ID db42a60e
> error: Failed dependencies:
>         libc.so.6.1()(64bit) is needed by openssl-0.9.7a-5
>         libc.so.6.1(GLIBC_2.2)(64bit) is needed by openssl-0.9.7a-5
>         libc.so.6.1(GLIBC_2.3)(64bit) is needed by openssl-0.9.7a-5
>         libcom_err.so.3()(64bit) is needed by openssl-0.9.7a-5
>         libdl.so.2()(64bit) is needed by openssl-0.9.7a-5
>         libdl.so.2(GLIBC_2.0)(64bit) is needed by openssl-0.9.7a-5
>         libdl.so.2(GLIBC_2.1)(64bit) is needed by openssl-0.9.7a-5
>         libgssapi_krb5.so.2()(64bit) is needed by openssl-0.9.7a-5
>         libk5crypto.so.3()(64bit) is needed by openssl-0.9.7a-5
>         libkrb5.so.3()(64bit) is needed by openssl-0.9.7a-5
>         libresolv.so.2()(64bit) is needed by openssl-0.9.7a-5
>         libz.so.1()(64bit) is needed by openssl-0.9.7a-5
> 

glibc*
zlib*
krb5*
...

$man rpm
--import /mnt/cdrom/*KEY
--requires
--whatrequires
...

eg.
# rpm -qf  /lib/libdl.so.2
glibc-2.3.2-4.80.6



$rhn-applet-gui
$rhn-applet-tui

you get a list of available updates for your *current* insalled system

you can subscribe to rhn ~60 USD/year
https://rhn.redhat.com/


or
you can download all the updates you need by hand
<hint>wget</hint>

rpm -q --qf "%{arch} %{name}\n" package1 package2 ...
rpm -Fvh /path/to/your/packages/*


dependencies?
eg.
cd /path/to/your/packages
rpm -Uvh openssl* glib* krb5* you_need_more_1* you_need_more_2* ...





$man up2date

http://freshrpms.net/apt/


good luck ;-)


-- 
shrek-m





More information about the Snort-users mailing list