[Snort-users] Re: Apache for snort

Slighter, Tim tslighter at ...5174...
Thu May 8 07:56:13 EDT 2003


You might be better off going with the source code for Apache_1.3.27 if you
plan to use PHP and/or SSL.  There are still some buggy issues between PHP
and Apache-2*.

-----Original Message-----
From: LAKHANI, AAMIR [mailto:AAMIR.LAKHANI at ...9099...]
Sent: Thursday, May 08, 2003 7:50 AM
To: 'snort-users at lists.sourceforge.net'
Subject: RE: [Snort-users] Re: Apache for snort


Okay, I am still having some problems. I have gotten Apache and MySQL
installed. I am trying to get php installed correctly and recieve the
following:

[root at ...9123... php]# rpm -ivh php-4.2.2-8.0.7.i386.rpm
warning: php-4.2.2-8.0.7.i386.rpm: V3 DSA signature: NOKEY, key ID db42a60e
error: Failed dependencies:
        libcrypto.so.2 is needed by php-4.2.2-8.0.7
        libssl.so.2 is needed by php-4.2.2-8.0.7

Appears OpenSSL is not installed correctly. I downloaded the latest RPM and
here is what I got:

[root at ...9123... download]# rpm -ivh openssl-0.9.7a-5.ia64.rpm
warning: openssl-0.9.7a-5.ia64.rpm: V3 DSA signature: NOKEY, key ID db42a60e
error: Failed dependencies:
        libc.so.6.1()(64bit) is needed by openssl-0.9.7a-5
        libc.so.6.1(GLIBC_2.2)(64bit) is needed by openssl-0.9.7a-5
        libc.so.6.1(GLIBC_2.3)(64bit) is needed by openssl-0.9.7a-5
        libcom_err.so.3()(64bit) is needed by openssl-0.9.7a-5
        libdl.so.2()(64bit) is needed by openssl-0.9.7a-5
        libdl.so.2(GLIBC_2.0)(64bit) is needed by openssl-0.9.7a-5
        libdl.so.2(GLIBC_2.1)(64bit) is needed by openssl-0.9.7a-5
        libgssapi_krb5.so.2()(64bit) is needed by openssl-0.9.7a-5
        libk5crypto.so.3()(64bit) is needed by openssl-0.9.7a-5
        libkrb5.so.3()(64bit) is needed by openssl-0.9.7a-5
        libresolv.so.2()(64bit) is needed by openssl-0.9.7a-5
        libz.so.1()(64bit) is needed by openssl-0.9.7a-5



[root at ...9123... download]# 

-----Original Message-----
From: shrek-m at ...348... [mailto:shrek-m at ...348...]
Sent: Wednesday, May 07, 2003 5:22 PM
To: snort-users at lists.sourceforge.net
Subject: [Snort-users] Re: Apache for snort


David Alonso De La Vega Tapage schrieb:
> http://www.rpmfind.net
> 
> the rpm dictionary .. !
> 
> LAKHANI, AAMIR wrote:
> 
>> Hi, I am following the snort enterprise implementation guide found on
>> superhac. The version 3.0 of the guide tells me I should obtain
>> Apache-2.0.X-X.i386.rpm at
>> ftp.redhat.com/pub/redhat/linux/9/en/os/i386/RedHat/RPMS. However, I 
>> cannot
>> find this package. I did find the package httpd-2.0.40-8-i386.rpm. When I
>> try to install that rpm I recieve an error stating I am missing
>> libcryto.so.2 and libssl.so.2 I am not sure where to find these 
>> packages and
>> how to install them. I tried searching redhat's ftp site with no luck.


_rhl-8.0_

$ rpm -q --whatprovides libcrypto.so.2 libssl.so.2
openssl-0.9.6b-33
openssl-0.9.6b-33


#rpm -Uvh path/to/package
#rpm -Uvh ftp://updates.redhat.com/9/path/to/openssl*

-- 
shrek-m



-------------------------------------------------------
Enterprise Linux Forum Conference & Expo, June 4-6, 2003, Santa Clara
The only event dedicated to issues related to Linux enterprise solutions
www.enterpriselinuxforum.com

_______________________________________________
Snort-users mailing list
Snort-users at lists.sourceforge.net
Go to this URL to change user options or unsubscribe:
https://lists.sourceforge.net/lists/listinfo/snort-users
Snort-users list archive:
http://www.geocrawler.com/redir-sf.php3?list=snort-users


-------------------------------------------------------
Enterprise Linux Forum Conference & Expo, June 4-6, 2003, Santa Clara
The only event dedicated to issues related to Linux enterprise solutions
www.enterpriselinuxforum.com

_______________________________________________
Snort-users mailing list
Snort-users at lists.sourceforge.net
Go to this URL to change user options or unsubscribe:
https://lists.sourceforge.net/lists/listinfo/snort-users
Snort-users list archive:
http://www.geocrawler.com/redir-sf.php3?list=snort-users




More information about the Snort-users mailing list