[Snort-users] Quick question...new mysql work ok?

Sherwood, Adam asherwood at ...9719...
Thu Jul 24 10:40:22 EDT 2003


> Date: Thu, 24 Jul 2003 06:14:03 -0700 (PDT)
> From: James Nonya <slave_tothe_box at ...131...>
> To: snort-users at lists.sourceforge.net
> Subject: [Snort-users] Quick question...new mysql work ok?
> 
> Does the new MySQL 4.0.14 work ok with Acid and Snort?
>
> Thanks!
> 
> James

ACID v0.9.6b21 and Snort 2.0.0 work for me, having gone from MySQL 3.23.52
to 4.0.13, with PHP 4.1.2 and Apache 1.3.27 on RH 7.3.  I would advise
anyone doing an upgrade to ensure dependencies are not broken between the
database, the web server, PHP, and ACID.  For example, the PHP MySQL
extension, php-mysql, depends on libmysqlclient.so.  In my case, upgrading
MySQL took me from libmysqlclient.so.10 to libmysqlclient.so.12, which broke
PHP, which broke ACID.  The smart solution is to upgrade PHP and php-mysql
along with MySQL.  Alternatively, obtaining a libmysqlclient.so.10 and
putting it in place next to libmysqlclient.so.12 will do in a pinch.  Making
an so.10 symlink to so.12, however, does not work.  Watch your dependencies,
and you'll be fine.

Have fun,

Adam





More information about the Snort-users mailing list