[Snort-users] Problem with snort 2.1.0 and redhat 9

Erek Adams erek at ...950...
Wed Dec 24 05:38:03 EST 2003


On Tue, 23 Dec 2003, Lang Hoang wrote:

> I have problem with snort 2.1.0 install on Redhat 9.  Snort won't start
> and there is no error for it. I run config, make and make install
> without problem, and mysql, php, acid seem working fine.  I have mysql,
> php, acid running no problem with snort 2.0.4 and 2.0.6 on this machine
> but not 2.1.0

Try typing this:

	/usr/local/bin/snort -V

Bet it gives you a version doesn't it?

Try typing this:

	/usr/local/bin/snort -T

Give you an error?  If so, remember that when you update your versions of
Snort from one to the next, you _HAVE_ to update your config files and
your rulesets.

If that's still not it, check the way you're starting Snort.  You could be
starting it via some startup script and the default install (RPM or
whatever) for your OS might be a bit crackheaded--Gee, RedHat doing
something crazy?!?! </sarcasm>--And install it into a different location
that the default /usr/local/bin/ .  Check the startup script and edit it
to point to the right version.

If both of those suggestions don't do it, try starting Snort _without_ the
-D flag.  It will actually tell you the error if it fails for some reason
if you don't have that flag.

If none work...  Let us know.

Cheers!

-----
Erek Adams

   "When things get weird, the weird turn pro."   H.S. Thompson




More information about the Snort-users mailing list