[Snort-users] postgresql backend

Per-Erik Persson pep at ...10690...
Thu Dec 4 06:36:01 EST 2003


You'll need the mysql-devel package as well.



tis 2003-12-02 klockan 22.44 skrev Frank Knobbe:
> On Tue, 2003-12-02 at 15:10, Nicholas Bernstein wrote:
> > I'm trying to compile snort with support for a mysql backend, but am
> > having problems getting it to work. I've tried several different
> > incarnations of the ./configure based on 
> > 	"./configure --with-postgresql --with-mysql"
> > 	"./configure --with-postgresql=/usr/include/pgsql --with-mysql"
> > 	"./configure --with-postgresql=/var/lib/pgsql --with-mysql"
> > 
> > I looked through the user manual, went through google results, and
> > searched the mailing list archives for '--with-postgresql'. I'm pretty
> > sure that this is a fairly common setup and was hoping someone could
> > point out what I'm doing wrong. ANY help would be greatly appreciated. 
> 
> 
> Uhm, are you indeed trying to use both databases? Postgres AND MySQL? If
> you only need MySQL support, all you need is --with-mysql. Make sure you
> have the MySQL client loaded on that box and the MySQL development files
> (sources for the client, at the very least libs and headers) on the box
> you compile this on. The production box only needs to have the
> libraries, but you need to compile on a box that does have the header
> files.
> 
> Regards,
> Frank
-- 
Per-Erik Persson <pep at ...10690...>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: Detta ?r en digitalt signerad	meddelandedel
URL: <https://lists.snort.org/pipermail/snort-users/attachments/20031204/14f25aae/attachment.sig>


More information about the Snort-users mailing list