[Snort-users] rule update causes seg fault

Josh.Sakofsky at ...10683... Josh.Sakofsky at ...10683...
Wed Dec 3 11:11:03 EST 2003


any ideas on this?
when i updated my rule set to the latest stable release, i get a seg 
fault....
i am running snort 2.0.5 on a redhat 9.0 box
the actually command run is: snort -D -i eth1 -c 
/etc/snort/snort-seg1.conf
the box is configured with 3 NICs, 2 for monitoring different segments and 
one for management
the 2 monitoring ports have no ip
i run 2 instances of snort, with each instances having it's own snort.conf 
file but pointing to the same rule directory
the instance for seg1 is the only one with a problem, the one for seg0 has 
no issue and runs fine
a diff of the 2 config files shows that only the $HOME_NET and 
$EXTERNAL_NET variables are different
if i run snort -Tc snort-seg1.conf, it tells me the config file is fine
once i roll back the rule update, snort runs both instances with no 
problem...
attached is the output from running snort in gdb with a where and a bt
please let me know if printing any variables might help....

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.snort.org/pipermail/snort-users/attachments/20031203/ab9bdd56/attachment.html>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: gdb-snort.txt
URL: <https://lists.snort.org/pipermail/snort-users/attachments/20031203/ab9bdd56/attachment.txt>


More information about the Snort-users mailing list