[Snort-users] Problem with compiling snort

dunervst at ...348... dunervst at ...348...
Wed Dec 3 08:42:23 EST 2003

Hi together,

i have a Problem with every snort version out there. The issue is that i compile snort like that:

./configure --with-mysql
make check
make install

during the configure option it shows me that mysql support is ok. When i am done, there is nothing. No /etc/snort, no subsys/snort, no var/log/snort and no /usr/sbin/snort. There is really nothing. When i make a rpm of the tar file it is working, but i can´t use it with mysql. After rpmbuild i got 2 Pakages snort and snort-mysql. I installed both but every time i restart snort it tells me that it can´t shut down the service. In the message log 

snort: database: 'mysql' support is not compiled into this build of snort
snort: FATAL ERROR: If this build of snort was obtained as a binary distribution (e.g., rpm, or Windows), then check for alternate builds that contains the necessary 'mysql' support.  If this build of snort was compiled by you, then re-run the the./configure script using the '--with-mysql' switch. For non-standard installations of a database, the '--with-mysql=DIR' syntax may need to be used to specify the base directory of the DB install.  See the database documentation for cursory details (doc/README.database). and the URL to the most recent database plugin documentation.

What does that error came from ? How to fix it. I tried to compile manually, but it is not working. My mysql server it up and running very well. Snort db and tables are created via the snort_db_install_script.

Please Help me, i tried snort-2.0.5 and snort 2.0.4 and snort 2.0.2
Thank you in advance
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.snort.org/pipermail/snort-users/attachments/20031203/b66149d7/attachment.html>

More information about the Snort-users mailing list