[Snort-users] php is too old !?!?

SRH-Lists giermo at ...8381...
Tue Apr 29 13:54:10 EDT 2003


Look in acid_db_common.php for a bit that looks something like this:


  /* only version PHP 4.0.4+ or 4.1+.* are valid */ 
  if ( !( ($version[0] >= 4) && ( ( ($version[1] == 0) && ($version[2]
>= 4) ) ||
                                    ($version[1] > 0)  ) ) )

However, 4.3.1 should pass that test.  $version[0] is the major version,
in this case 4, and $version[1] is the rev, in this case 3 which is
greater than 0, so that should be true also.

Make sure that the code in the acid you are running is something like
this.  If it is not, go to 
http://www.andrew.cmu.edu/~rdanyliw/snort/snortacid.html 
and get a new version.


> 
> I tried to get the acid from snort/contrib
> 
> and now the acid ONLY return the "green frame" with   
> "Analysis Console
> for Intrusion Databases" at top.
> 
> Yes, I know. PHP is crazy but the ACID is to.
> 
> On Tue, 2003-04-29 at 17:14, David Alonso De La Vega Tapage wrote:
> > PHP is crazy ..   :-)
> > 
> > when I have this problem ..  I can solve it with new 
> actualization of 
> > php ( RH rpm ).
> > 
> > 
> > Filipe Dantas wrote:
> > 
> > >The acid return this message:
> > >
> > >
> > >PHP ERROR: Incompatible version: Version 4.3.1 of PHP is too old. 
> > >Please upgrade to version 4.0.4 or later
> > >
> > >?!?!??!




More information about the Snort-users mailing list