[Snort-users] Installing Snort with PHP, MySQL, ACID,etc

Patrick S. Harper lists at ...4250...
Tue Apr 22 07:02:06 EDT 2003


I am rewriting that document for RH9 with snort 2.  It should be ready
in a few days.  I can send you the working document if you want.  shoot
me an e-mail to patrick at ...4250... and I will send it to
you if you like. (guinea pigs wanted)


On Tue, 2003-04-22 at 02:42, Gary and El Byrnes wrote:
> Hi Patrick
> 
> Thanks a lot for your message. I have use the following as per your manual (Jesus! Just realized it was your personal one!).
> 
> I used ./configure --with-mysql --with-apache=/software/apache/apache_1.3.27 --enable-sockets -with-zlib-dir=/usr/local --with-gd
> 
> It is a funny story. I installed everything according to your manual on RedHat 8.0 and it all worked, including PHP and the PHP script of the networking tool that you provided the link for. This time, on a cleanly installed (from scratch - not upgraded) RH9.0 I can't get the same thing to work. I already looked into FAQs on the main php site, they had no resolution for my problem except some vague suggestion. 
> 
> I also tried upgrading the RH8.0+Snort1.9.1 to RH9.0+Snort2.0. Nearly everything is working fine except there is something wrong with the path (even though I added /usr/local/mysql/lib/mysql and /usr/local/lib to /etc/ld.so.conf and ran ldconfig as a root, when I do echo $PATH none of them come up, unless I manually go PATH=....., of course it is lost on the reboot), the result of which is when I type mysql or mysql -p the commands are not recognised. When I add the above two lines to the PATH=... mysql starts working and accepting mysql and mysql -p. I am wondering what went wrong there.
> 
> I hope I am making sense. I am very new to all this, but loving it.
> 
> Best regards
> 
> Elvira
> 
> PS I am so glad your fiancée didn't stumble over these problems :)
>   ----- Original Message ----- 
>   From: Patrick S. Harper 
>   To: Gary and El Byrnes 
>   Cc: snort-users at lists.sourceforge.net 
>   Sent: Tuesday, April 22, 2003 3:41 PM
>   Subject: Re: [Snort-users] Installing Snort with PHP, MySQL, ACID,etc
> 
> 
>   What was the ./configure command you used with PHP?
> 
> 
>   On Sun, 2003-04-20 at 19:33, Gary and El Byrnes wrote:
>   > Hi Everybody
>   > 
>   > I hope someone can help me with my problem. I want to install Snort on RedHat 9.0. I have installed zlib, libpcap, mysql 4., apache 1.3. All these things work. 
>   > 
>   > Next thing I am supposed to install PHP. When I run ./configure --prefix=/www --activate-module=src/modules/php4/libphp4.a
>   > I get error messages at the end with php modules. I check the src/modules/php4/ and there is no libphp4.a file in it.
>   > 
>   > When I try to run a php webpage as a test I get a Not Found error.Obviously php isn't running.
>   > 
>   > I have re-run the installation from scratch several times by now, and it is still the same.
>   > 
>   > Is this something to do with RedHat 9.0? I didn't have this problem on 8.0. Is there any way to fix this without going back to 8.0.
>   > 
>   > Thanks very much in advance.
>   > 
>   > Regards
>   > 
>   > Elvira
>   -- 
>   Patrick S. Harper | CISSP MCSE
>   patrick at ...4250...
>   www.internetsecurityguru.com
> 
>   "If we aren't supposed to eat 
>   animals, why are they made
>   of meat?"
> 
-- 
Patrick S. Harper | CISSP MCSE
patrick at ...4250...
www.internetsecurityguru.com

"If we aren't supposed to eat 
animals, why are they made
of meat?"






More information about the Snort-users mailing list