FW: [Snort-users] Acid and PHP Redhat 8.0

SecurityAdmin at ...7345... SecurityAdmin at ...7345...
Thu Apr 10 13:13:03 EDT 2003


Here is an exerpt from my install doc, it's for FreeBSD but I used it on RH8
and it worked...

You may only need to do the last line, but PTH may also be needed...the
./configure lines may be your best clue to what's missing

Install in this order.....  --prefix just installs in custom directories
A) Mysql
# cd /home/software/mysql-3.23.49
# ./configure --prefix=/home/mysql
# make
# make install
- add a mysql group # pw groupadd mysql
- add a mysql user #adduser -g mysql mysql
- create the main system tables
# /home/mysql/mysql_install_db
- from # /home/mysql/share/mysql select the template that suits your
needs best (my- medium.cnf etc) and copy it as my.cnf under the /etc
directory
# cp /home/mysql/share/mysql/my- medium.cnf /etc/my.cnf
-Change the owners of the mysql directories
# chown -R root /home/mysql
# chown -R mysql /home/mysql/data
# chgrp -R mysql /home/mysql
-Start the mysql server
# /home/mysql/bin/safe_mysqld --user=mysql &
- set the password for root in mysql (this can be done later using
phpmysqladmin)

B) PTH
# cd /home/software/pth-1.4.1
# ./configure
# make
# make install

C) Install Apache
# cd /home/software/apache-2.0.39
# ./configure --prefix=/home/www --enable-module=so
# make
# make install

D) Install PHP
# cd /home/software/php-4.2.1
# ./configure --with- mysql --with-tsrm-pth --withapxs2=/
home/www/bin/apxs
# make
# make install
# copy the php.ini-dist file to /usr/local/bin/php.ini
cp php.ini-dist /usr/local/bin/php.ini
- edit the php.ini file and rem out error reporting
- edit the httpd.conf file and add
-AddType application/x- httpd-php .php

Regards,
Wayne

http://www.inetsecurity.info

-----Original Message-----
From: Tom Morgan [mailto:TomMorgan at ...8835...]
Sent: Wednesday, April 09, 2003 9:14 AM
To: SnortUsers
Subject: [Snort-users] Acid and PHP Redhat 8.0


Hello,
I am getting this info after connecting to my apache server using acid:
PHP ERROR: PHP build incomplete: the prerequisite MySQL support required to
read the alert database was not built into PHP. Please recompile PHP with
the necessary library (--with-mysql)
I have recompiled with the --with-mysql and get the same results.

Anyone have a solution?

Thanks,
Tom Morgan



-------------------------------------------------------
This SF.net email is sponsored by: Etnus, makers of TotalView, The debugger 
for complex code. Debugging C/C++ programs can leave you feeling lost and 
disoriented. TotalView can help you find your way. Available on major UNIX 
and Linux platforms. Try it free. www.etnus.com
_______________________________________________
Snort-users mailing list
Snort-users at lists.sourceforge.net
Go to this URL to change user options or unsubscribe:
https://lists.sourceforge.net/lists/listinfo/snort-users
Snort-users list archive:
http://www.geocrawler.com/redir-sf.php3?list=snort-users





More information about the Snort-users mailing list