[Snort-users] PHP build incomplete error on ACID

Shreyas Doshi shreyas.doshi at ...6955...
Tue Sep 24 09:16:03 EDT 2002


Yes, I did create the snort schema in MySQL, if that is what you are
referring to. Snort is writing to the database just fine. The problem
seems to be that ACID thinks that PHP is not compiled with MySQL
support; though I have used --with-mysql for the ./configure command.
Also, I have installed the php-mysql package though this was not
mentioned in the instructions.

-----Original Message-----
From: Slighter, Tim [mailto:tslighter at ...5174...] 
Sent: Tuesday, September 24, 2002 7:33 AM
To: Shreyas Doshi; snort-users at lists.sourceforge.net
Subject: RE: [Snort-users] PHP build incomplete error on ACID

Once you did the build, did you go into mySQL and source the
create_mysql
script in the newly created snort database ?  

-----Original Message-----
From: Shreyas Doshi [mailto:shreyas.doshi at ...6955...]
Sent: Friday, September 20, 2002 12:16 PM
To: snort-users at lists.sourceforge.net
Subject: [Snort-users] PHP build incomplete error on ACID


Hi all,

I originally posted this message off google groups and did not receive
any replies. Hence, I am re-posting it directly on the list. Any help
will be deeply appreciated.

I installed snort, acid, phplot, adodb, gd, php, and mysql as per the
instructions on
http://www.andrew.cmu.edu/~rdanyliw/snort/acid_config.html
on a Redhat 7.2 box running apache.

When I open the ACID URL, I get the following error:

PHP ERROR: PHP build incomplete: the prerequisite MySQL support
required to read the alert database was not built into PHP. Please
recompile PHP with the necessary library (--with-mysql)

The fact is, however, that I have compiled PHP with MySQL support. I
also tried installing php-mysql, guessing that maybe that could remedy
the situation.That did not work either.  I also tried to modify the
php.ini file in
/etc to say

"extension=mysql.so"
and
"extension_dir=.:/usr/lib/php4"   ('cos thats where mysql.so is
located).

Then, restarted httpd, but even this did not work.

First question:
Have I done the right thing in the php.ini file?

Second question:
How do I get rid of this error?

I am using Linux after a gap of 6 years, so I might be making some
mistakes - cant' figure out what though.

Cheers,
Shreyas



-------------------------------------------------------
This sf.net email is sponsored by:ThinkGeek
Welcome to geek heaven.
http://thinkgeek.com/sf
_______________________________________________
Snort-users mailing list
Snort-users at lists.sourceforge.net
Go to this URL to change user options or unsubscribe:
https://lists.sourceforge.net/lists/listinfo/snort-users
Snort-users list archive:
http://www.geocrawler.com/redir-sf.php3?list=snort-users




More information about the Snort-users mailing list