[Snort-users] Problem compiling for flexresp on Solaris.

Colin Wu wucolin at ...2181...
Sat Sep 21 05:10:03 EDT 2002


Erek,

Thanks for the tip. I installed gnu grep 2.5. Unfortunately, that didn't 
fix the make error.

Erek Adams wrote:

>On Fri, 20 Sep 2002, Colin Wu wrote:
>
>  
>
>>It's possible I may not have done a thorough enough search of the list
>>archives, but I have not found references to this particular problem:
>>
>>I'm trying to build snort-1.8.6 on a Solaris8 host for flexresp.
>>(Without flexresp it builds just fine.) I'm getting the following errors
>>on 'make':
>>    
>>
>
>Colin,
>
>	One thing that may be giving you grief--./configure uses a 'grep -q'
>in one of the checks.  Since on Solaris /usr/bin/grep doesn't have a -q, you
>can either install GNU Grep or use /usr/xpg4/bin/grep which does handle -q.
>
>	Another suggestion:  Get to the latest revision of snort (1.8.7).  I'd
>be curious to see if the newer version did the same thing.
>
>	Hope that helps!
>
>-----
>Erek Adams
>Nifty-Type-Guy
>TheAdamsFamily.Net
>  
>






More information about the Snort-users mailing list