[Snort-users] Flexresp Support and libnet ver 1.1.0

Chris Green cmg at ...1935...
Wed Sep 18 11:09:06 EDT 2002


Jim Cliver <jim.c at ...3008...> writes:

> Hello,
>
> I am trying to configure snort 1.8.7 with --enable-flexresp switch. 
> I've compiled successfully the latest version of libnet (1.1.0) of
> 8/5/02 as stated (though not by release) in the INSTALL doc.  According
> to the README doc of libnet 1.1.0 the API has been redesigned, this
> change has broken the flexresp function and cannot be compiled any
> longer.
>
> My question is, is there an upcoming release of snort that will use the
> newly available libnet API? 

Not in the foreseable future. Patches are welcome but the new libnet
API is another task to learn in and of itself and it would break the
precalculation stuff that was done most likely because you have to get
down and dirty with the new api to do the stuff that snort does.
-- 
Chris Green <cmg at ...1935...>
A good pun is its own reword.




More information about the Snort-users mailing list