[Snort-users] Snort Installation?

Erek Adams erek at ...577...
Mon Sep 9 10:06:05 EDT 2002


On Mon, 9 Sep 2002, Daniel Curry wrote:

> I am trying to install snort on two new boxes. My
> question is why I am unable to find libmysqlclient.so.10?
>  I do have LIB_LIBRARY set up to include, but no luck.
>
>
>
> rpm -ivh snort-mysql-1.8.7-1snort.i386.rpm
> error: failed dependencies:
>         libmysqlclient.so.10   is needed by snort-mysql-1.8.7-1snort
>
> /usr/local/lib/mysql/libmysqlclient.so.10
>
>
>  0 lrwxrwxrwx    1 root     root           24 Sep  6 15:09
> /usr/local/lib/mysql/libmysqlclient.so.10 -> libmysqlclient.so.10.0.0
>
> 140 -rwxr-xr-x    1 root     root       137944 Sep  6 15:09
> /usr/local/lib/mysql/libmysqlclient.so.10.0.0

Ditch the RPM's and roll your own.  I love the idea of RPM/Ports/PKG's, but
they all suffer from one thing:  Depending on someone else to do somehthing
the way that you would.

It's fairly simple to get snort to work out of the box.  Uncompress, untar, cd
<snortdir>, ./configure --with-mysql=/usr/local/lib/mysql/ && make && make
install and you're done.

-----
Erek Adams
Nifty-Type-Guy
TheAdamsFamily.Net





More information about the Snort-users mailing list