[Snort-users] Running Snort 1.9.0 from shell script

Eric Joe sysop at ...6291...
Mon Oct 14 19:35:05 EDT 2002


> On Mon, Oct 14, 2002 at 10:11:40PM -0400, Eric Joe wrote:
>> I had been running Snort 1.8.7 from a simple shell script like this
>>
>> #!/bin/sh
>> /usr/local/bin/snort -d -c /home/snort-1.9.0/etc/snort.conf -o &
>>
>> Now, with version 1.9.0 I get this error when I run it from a shell.
>>
>> ERROR => Undefined variable name: (../rules/exploit.rules:22): SMTP
>>
>> I am running the bash shell on
>>
>> 2.4.18-5smp kernel
>>
>> If I type out the same exact command in a shell, it works fine!
>>
>> I am baffled. Can someone set me straight?
>
> IFAIK
> 	var SMTP $HOME_NET
> has been replaced with
> 	var SMTP_SERVERS $HOME_NET
>
> or you have a misspelled rule. Double-check your $VARIABLE useage
> against what you define with 'var VARIABLE value' statements.


Michael,
Thanks for the reply. I installed Snort fresh and it only gives me that
error if I run it from my little shell script, otherwise it works fine, so
its prob not a mis-named variable.
Thanks

-- 
Eric Joe
Network Operations
Journey's End Internet/Computer Connection Inc






More information about the Snort-users mailing list