[Snort-users] snort & mysql; not using the password?!

Folkert van Heusden folkert at ...7104...
Tue Oct 8 08:26:03 EDT 2002


Hi,

I'm trying to get snort 1.8.7 to work with mysql 3.23.39
In snort.conf I added the following line:
  output database: log, mysql, user=userxxx dbname=xxx host=localhost
When I logon into myqsl like this:
mysql -u userxxx -h localhost -p snort
all works fine!
But if I try to start snort like this:
/usr/local/bin/snort -c /usr/local/etc/snort.conf -dvi ppp0
I get the following error:
database: compiled support for ( mysql )
database: configured to use mysql
database: database name = snort
database:          user = userxxx
database:          host = localhost
database: password is set
Node unique name is: 213.84.46.114
database:   sensor name = 213.84.46.114
database:     sensor id = 1
database: schema version = 105
database: using the "log" facility
limit == 128
UnifiedAlertFilename = snort.alert
database: compiled support for ( mysql )
database: configured to use mysql
database:          user = userxxx
database: database name = xxx
database:          host = localhost
Node unique name is: 213.84.46.114
database:   sensor name = 213.84.46.114
database: mysql_error: Access denied for user: 'snortman at ...274...' (Using
password: NO)

This is rather strange! Suddenly it takes the password for the
database-name, and when snort tries to connect to the database
it doesn't use the password!

Anyone got a clue what can be the cause of this?


Folkert van Heusden

------------------------------------------------------------
Folkert van Heusden
Mobile phone: +31-6-41278122
Work e-mail address: f.v.heusden at ...7105...
ICQ number: 105675015
PGP-key available on request
------------------------------------------------------------






More information about the Snort-users mailing list