[Snort-users] --enable-flexresp

Jeff Nathan jeff at ...950...
Thu Oct 3 15:54:02 EDT 2002


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Larry,

What problems are you having with compiling snort with --enable_flexresp? 
Exactly what happens?

The snort packages you're  trying to install are already compiled and are 
dynamically linked to a particular version of libpcap.  You may be able to 
simply create a symlink from your version of libpcap to the version the 
snort binary is looking for, but with a newer major version of libpcap, the 
shared object may be incompatible.

If your system is using a newer or incompatible version of libpcap, you'll 
have to build from source or use a statically compiled snort binary for 
your architecture.

- -Jeff

- --On Thursday, October 03, 2002 16:07:16 -0500 Larry Calow 
<lcalow at ...7074...> wrote:

>
> I have always had problems getting snort to compile with
> --enable-flexresp and work. I have also had problems with the Redhat and
> Mandrake RPM's. It was a hit or miss thing getting it to work.  It seems
> that snort is looking for a file /usr/lib/libpcap.so.0.6.2 if it doesn't
> find this exact file it will bomb out I have used tried versions
> libpcap.so.0.6 no good I expected as much not downward compatible, but
> version libpcap.so.0.7 no good same error.  So okay the work around is to
> have version libpcap.so.0.6.2 and version libpcap.so.0.7 of the file in
> this directory. Will a symbolic link work???
> Larry


- --
http://www.snort.org/~jeff       (pgp key available)
"Great spirits have always encountered violent opposition from mediocre
minds."
- - Albert Einstein
    
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.7 (OpenBSD)

iD8DBQE9nMlEEqr8+Gkj0/0RAn5NAKCY2EaxViaHWc2Ux5xrx0wx9KT8KACgmj5S
wgkaW+uo1vnN8rVOrgfS+DI=
=WMUA
-----END PGP SIGNATURE-----





More information about the Snort-users mailing list