[Snort-users] Not Compiled for MySQL

John Sage jsage at ...2022...
Sat May 25 15:09:01 EDT 2002


Matt:

This seems to come up pretty often; don't know what's broke or why
it's not fixed, but try doing this:

./configure --with-mysql=/usr/

and let the rest fill in by itself.


HTH..

- John
-- 
You simply can never have too many shells

PGP key      http://www.finchhaven.com/pages/gpg_pubkey.html
Fingerprint  FE 97 0C 57 08 43 F3 EB 49 A1 0C D0 8E 0C D0 BE C8 38 CC B5 



On Sat, May 25, 2002 at 04:34:10PM -0500, Matt Richter wrote:
> I am having trouble compiling snort for MySQL
>  
> Here is the error from snort -c /etc/snort/snort.conf
> ***************Snip*******************************
> database: compiled support for ( )
> database: configured to use mysql
> database: mysql support is not compiled in this copy
>  
> Check your configuration file to be sure you did not mis-spell "mysql".
>  If you did not, you will need to reconfigure and recompile ensuring that
>  you have set the correct options to the configure script. Type 
>  "./configure --help" to see options for the configure script.
> Fatal Error, Quitting..
> ***************Snip*******************************
>  
> Here are my versions:
> OS: RH7.2 (New install)
> Snort Ver: Version 1.8.6 (Build 105)
> MySQL Binaries Installed :
>   MySQL-3.23.49a-1.i386.rpm   
>   MySQL-client-3.23.49a-1.i386.rpm  
>   MySQL-devel-3.23.49a-1.i386.rpm 
>   MySQL-shared-3.23.49a-1.i386.rpm
>  
> MySQL is running and resonding
>  
> Location of MySQL Includes (mysql.h): /usr/include/mysql/mysql.h
> Configure command line: ./configure --with-mysql=/usr/include/mysql/
> Error in ./configure output: "checking for mysql... no"
> Snort.conf output config: "output database: log, mysql, user=root password=xxxx dbname=snort host=localhost"
>  
> I've tried pointing the --with-mysql= to any directory that had anything to do with mysql and received the same output error. I have even tried downloading and extracting the mysql tar file and pointing to the "include" directory created from tar file.
> I noticed that if i configure with "./configure --with-mysql" , the output from the ./configure says "checking for mysql... yes". However, if I then make and make install, the "database: mysql support is not compiled in this copy" error is repeated.
>  
> --Matt




More information about the Snort-users mailing list