[Snort-users] snort and acid prob when connecting to mysql

Poppi, Sandro Sandro.Poppi at ...3316...
Wed Mar 20 03:51:05 EST 2002


Snorters,

today I ran into a weird problem which I can't explain:

Yesterday I updated snort to the actual 1.8.4 version. I'm running RedHat
7.2, intel, using ACID 0.9.6b21 and mysql 3.23.41. When I called ACID I got

Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)

although ACID worked before perfectly. According to the ACID FAQ I changed
/etc/my.cnf to point to /tmp/mysql.sock and ACID worked again (although very
strange behaviour I can't explain myself).

Now I started snort and what happened? Well

Can't connect to local MySQL server through socket
'/var/lib/mysql/mysql.sock' (2)

where /var/lib/mysql/mysql.sock was the original location. I'm lost! The
only thing I remember what might have changed on that machine is I updated
RedHat with the actual RPMS available from RedHat.

How does ACID and/or ADODB (I'm using v1.80) find out which socket to use?

Any suggestion?

TIA,
Sandro




More information about the Snort-users mailing list