[Snort-users] built with mysql, but snort says I didn't

tbasilio at ...6128... tbasilio at ...6128...
Tue Jun 18 14:47:04 EDT 2002


I'm using FreeBSD 4.6-STABLE, and am trying to install snort 1.8.6 from
source. I built with mysql like this:
 
./configure -with-mysql=/usr/local/libexec
 
MySQL is installed and working, I use it often. When I try to start
snort like this:
 
# snort
 
I get the following error:
 
 
Log directory = /var/log/snort
 
Initializing Network Interface rl0
using config file /etc/snort.conf
Initializing Preprocessors!
Initializing Plug-ins!
Initializating Output Plugins!
Parsing Rules file /etc/snort.conf
 
+++++++++++++++++++++++++++++++++++++++++++++++++++
Initializing rule chains...
No arguments to frag2 directive, setting defaults to:
    Fragment timeout: 60 seconds
    Fragment memory cap: 4194304 bytes
Stream4 config:
    Stateful inspection: ACTIVE
    Session statistics: INACTIVE
    Session timeout: 30 seconds
    Session memory cap: 8388608 bytes
    State alerts: INACTIVE
    Scan alerts: ACTIVE
    Log Flushed Streams: INACTIVE
No arguments to stream4_reassemble, setting defaults:
     Reassemble client: ACTIVE
     Reassemble server: INACTIVE
     Reassemble ports: 21 23 25 53 80 143 110 111 513
     Reassembly alerts: ACTIVE
     Reassembly method: FAVOR_OLD
Back Orifice detection brute force: DISABLED
Using LOCAL time
database: compiled support for ( )
database: configured to use mysql
database: mysql support is not compiled in this copy
 
 Check your configuration file to be sure you did not mis-spell "mysql".
 If you did not, you will need to reconfigure and recompile ensuring
that
 you have set the correct options to the configure script. Type 
 "./configure --help" to see options for the configure script.
 
Fatal Error, Quitting..
 
 
 
I have tried rebuilding snort, always using the mysql flag for the
configure, but I get the same error. After three builds, I attempted to
use the previous version 1.8.5, and I get the same error. My snort.conf
is configured with most the defaults, but with MY network information
and the output plugin set up for mysql.
 
Anyone have some ideas?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.snort.org/pipermail/snort-users/attachments/20020618/2315d35c/attachment.html>


More information about the Snort-users mailing list