[Snort-users] Snort 1.8.7 won't compile!

Sheahan, Paul (PCLN-NW) Paul.Sheahan at ...2218...
Wed Jul 31 14:12:04 EDT 2002


I'm currently running Snort 1.8.4 on Red Hat Linux 7.0. I dreaded trying to
upgrade because it ALWAYS screws up. Sure enough I downloaded 1.8.7 and
tried ./configure, then make. Make gives the errors below. Afterward I tried
the RPM for the heck of it too, but it complained that it needed Libpcap
0.6.2. So I tried to compile libpcap 0.6.2 as well, and that compile bombed
too! Can anyone assist? Thanks


/usr/include/arpa/inet.h:73: parse error before `__net'
In file included from snort.h:54,
                 from snort.c:46:
/usr/include/rpc/xdr.h:301: parse error before `uint8_t'
/usr/include/rpc/xdr.h:303: parse error before `uint16_t'
/usr/include/rpc/xdr.h:305: parse error before `uint32_t'
In file included from /usr/include/netdb.h:41,
                 from snort.h:77,
                 from snort.c:46:
/usr/include/bits/netdb.h:32: parse error before `uint32_t'
/usr/include/bits/netdb.h:32: warning: no semicolon at end of struct or
union
In file included from snort.h:77,
                 from snort.c:46:
/usr/include/netdb.h:184: parse error before `__net'
/usr/include/netdb.h:201: parse error before `__net'
In file included from snort.h:231,
                 from snort.c:46:
decode.h:651: field `ip_src' has incomplete type
decode.h:652: field `ip_dst' has incomplete type
decode.h:713: field `gwaddr' has incomplete type
decode.h:735: Internal error: Segmentation fault.
Please submit a full bug report.
See <URL:http://www.gnu.org/software/gcc/bugs.html> for instructions.
make[2]: *** [snort.o] Error 1
make[2]: Leaving directory `/root/snort-1.8.7'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/snort-1.8.7'
make: *** [all-recursive-am] Error 2







More information about the Snort-users mailing list