[Snort-users] cant get Apache to launch

Robert Schwartz robert at ...5775...
Sun Jul 7 11:37:02 EDT 2002


Hopefully this won't be the blind leading the blind (I'm no uber apache
expert myself) but I've been down this path at least once.

> [crit] (98Address already in use: make_sock: could not bind 
> to port 443

Either you have a process using this port already:

netstat -an |grep 443
netstat -an |grep LISTEN

something like that to see if you have something listening.

 - or -

You need to do the following:

apachectl stop


> 
> here are some configs from  /usr/local/apache/conf/httpd.conf
> 
> Listen 192.168.1.5:443

Comment this line back out, this isn't for SSL, it's for http (apachectl
startssl will ignore this anyway).

> ....
> Under Dynamic Shared  Object (DSO)  Support section:
> <IfDefine SSL>
> 	Listen 443
> </IfDefine SSL>

Comment this section out, I have no idea where this came from.  If this
was in the doc you were reading then it's still worth commenting out for
troubleshooting and re-read what was going on here.

> 
> ......
> Port 443
> 
> Under SSL support
> <IfDefine SSL>
> 	Listen 443
> </IfDefine SSL>
> 

Change this to:
Listen 192.168.1.5:443

if you have multiple IP's interfaces.  If you only have one, then you
can leave it as "443" or make it "192.168.1.5:443" it won't make much of
a difference.

> ServerName 192.168.1.5

This only changes the name in the host HTTP headers, so it's not super
important (if you want to hide the machine's host name





More information about the Snort-users mailing list