[Snort-users] Barnyard Solaris 2.6 make issue

Steve Rudolph srudolph at ...4612...
Tue Jan 29 07:30:06 EST 2002


I got the latest cvs today and configured and compiled and now this is the
error that I get:

gcc  -g -O2 -Wall  -o barnyard  barnyard.o configparse.o mstring.o
strlcatu.o strlcpyu.o util.o spool.o sid.o debug.o classification.o
output-plugins/libop.a input-plugins/libdp.a -lsocket
Undefined                       first referenced
 symbol                             in file
inet_ntoa                           output-plugins/libop.a(op_logdump.o)
(symbol belongs to implicit dependency /usr/lib/libnsl.so.1)
ld: fatal: Symbol referencing errors. No output written to barnyard
collect2: ld returned 1 exit status
make[3]: *** [barnyard] Error 1
make[3]: Leaving directory `/home/srudolph/barnyard-0.1.0-cvs/src'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/srudolph/barnyard-0.1.0-cvs/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/srudolph/barnyard-0.1.0-cvs'
make: *** [all-recursive-am] Error 2

Help please!

Steve

"Andrew R. Baker" wrote:

> Steve Rudolph wrote:
> >
> > I am trying to compile Barnyard on a Solaris 2.6 box and I just get all
> > sorts of errors when I run make.
> > I went to the cvs and got the most recent files and tried agian and got
> > the below....again.
>
> Can you try again with the CVS checkout of barnyard?  I do not think the
> Solaris patches are in beta4.
>
> -A
>
> _______________________________________________
> Snort-users mailing list
> Snort-users at lists.sourceforge.net
> Go to this URL to change user options or unsubscribe:
> https://lists.sourceforge.net/lists/listinfo/snort-users
> Snort-users list archive:
> http://www.geocrawler.com/redir-sf.php3?list=snort-users

--
Steve Rudolph CCSA, CCSE
Network Security Engineer
Internet Operations Center
Southfield, MI







More information about the Snort-users mailing list