[Snort-users] Snort install

Chris Green cmg at ...671...
Thu Jan 17 15:05:04 EST 2002


"Warrick FitzGerald" <wfitzgerald at ...4613...> writes:

> 1.  (*) text/plain          ( ) text/html           
>
> Hi All,
>  
> I know this is a real newbie question, but Im sorry I'v been stuck for a
> day and a half and really need some help. 
>  
> When installing "snort-1.8.1-1mdk.i586.rpm" i get the following error :

Warning: thats a very old version of snort

>
>  
> error: failed dependencies:
>         libpcap >= 0.4 is needed by snort-1.8.1-1mdk
>         libpcap.so.0   is needed by snort-1.8.1-1mdk
>  
> Yes this seems simple and I know Im going to feel stupid when I hear the
> answer but here is what I have done to fix the problem.
>  
> A. Tried to install libpcap, but am not 100% sure how to tell if it is
> installed correctly. However rpm -q reveals that it is not

rpm -q libpcap

>  [root at ...4614... root]# rpm -qa | grep libp libpng2-1.0.12-2mdk
> libpilot-link4-0.9.5-3mdk
>     
>     the confusing thing though is that tcpdump works ???? HOW ????

Statically linked pcap into the binary.
>  
> B. My Path looks something like this :

FYI $PATH doesn't have anything to do with that library problem. 
>  
> If anyone can tell me what Im doing wrong, I would really appreciate
it.

You need to install libpcap, preferably a very current one.  I'd
recommend downloading the current beta pcap and compiling snort
against that.

When you compile snort, use --with-libpcap-libraries=~/src/libpcap---
--with-libpcap-libraries=~/src/libpcap-includes=~/src/libpcap---
-- 
Chris Green <cmg at ...671...>
Don't use a big word where a diminutive one will suffice.




More information about the Snort-users mailing list