[Snort-users] Can't Compile 1.8.4beta2

Scott Fringer fringsm at ...5133...
Thu Feb 28 06:50:43 EST 2002


Hello,
  I've been running an older version of Snort for a while and decided to
get current, so I downloaded the source for 1.8.4beta2.
  I am building/running on a Debian Linux system, with MySQL (3.23.47)
support.
  ./configure runs fine (./configure  --with-openssl=/usr/local/ssl
--with-mysql=/usr/local/mysql), it's during the actual make process that I
encounter the following error:

/usr/local/lib/libmysqlclient.a(my_compress.o): In function
`my_uncompress':
my_compress.o(.text+0x9a): undefined reference to `uncompress'
/usr/local/lib/libmysqlclient.a(my_compress.o): In function
`my_compress_alloc':
my_compress.o(.text+0x12a): undefined reference to `compress'

  Any thoughts on what the root cause is?  Snort 1.8.1 compiles fine with
the same support files.  I have also found if I edit the Makefile and
change the following lines, 1.8.4beta2 will compile fine also.

Original:

 CPPFLAGS = -I/usr/local/include -DENABLE_MYSQL
-I/usr/local/ssl/include -DENABLE_SSL

Changes:

 CPPFLAGS = -I/usr/include/pcap -I/usr/local/mysql/include -DENABLE_MYSQL
-I/usr/local/ssl/include -DENABLE_SSL

Original:

 LDFLAGS =  -L/usr/local/lib -L/usr/local/ssl/lib

Chanegs:

 LDFLAGS = -L/usr/local/mysql/lib -L/usr/local/ssl/lib


Thanks,
 Scott

Scott Fringer                              Shands Healthcare @ U.F.
Network Systems Analyst                        Gainesville, FL





More information about the Snort-users mailing list