[Snort-users] compiling snort with db-logging feature result in error

Heyde Fritjof fritjof.heyde at ...5034...
Thu Feb 21 05:34:20 EST 2002


Hi Snort-Users,

I have a problem with the snort-db logging feature.

When I run the configure script with mysql or postgresql support like
./configure --with-mysql

it runs through without errors, and give me when it checks for mysql this:
checking for pcap_datalink in -lpcap... yes
checking for mysql... yes
checking for compress in -lz... yes

ok! fine till here,

then I do
make
and 
make install

then when I try to start snort with
snort -i ppp0 -c /<snortdir>/snort.conf
I get the following:
database: compiled support for ( )
database: configured to use mysql
database: mysql support is not compiled in this copy

and honestly I dont have a clue why it's not working.
I tried the same with postgresql and it results in the same error.

Do I do something terribly wrong?
I'm compiling in a directory where snort is allready installed! Maybe that
got something to do with it?

Anybody out there who could help me?

Greets
Bydlo

PS: I'm using Suse Linux 7.1
PPS: I hope I dont make a fool of myself writing this. :) In case the
question is really dumb. :)
PPPS: Excuse my english please, I'm not a native speaker!


============================================
Fritjof Heyde
IVM - Solve - It
Tel.: +49 89 31813-260
Fax: +49 89-3165825
Telefon mob.     : (0179) 2176262
Email: mailto:Fritjof.Heyde at ...5034...
============================================






More information about the Snort-users mailing list