[Snort-users] Win32 Device disappearance

Matt Whelan matt at ...5000...
Sun Feb 17 08:03:03 EST 2002


I have what on the face of it looks like a winpcap problem, except . . .

This makes NO sense to me, and probably everyone else,  but I'll throw
it out there anyway.

I updated my Win32 Snort from 1.81 to 1.83 today, and now it has "lost"
its interfaces.

I get this error:

     Initializing Network Interface
     ERROR: OpenPcap() device  open:
             Error opening adapter
     Fatal Error, Quitting..

Running snort -W confirms the apparent source of the problem:

     F:\Snort183\Snort>snort -W

     -*> Snort! <*-
     Version 1.8-WIN32 (Build 88)
     By Martin Roesch (roesch at ...1935..., www.snort.org)
     1.7-WIN32 Port By Michael Davis (mike at ...92...,www.datanerds.net/~mike)
     1.8-WIN32 Port By Chris Reid (chris.reid at ...3029...)
               (based on code from 1.7 port)

     Interface       Device          Description
    -------------------------------------------
     1		

F:\Snort183\Snort>

Note it shows only 1 interface (should be 3), and no device or
description.

Clearly this looks like a winpcap problem -- but I didn't touch winpcap,
and it still works as always (and with the same list of devices) with
Ethereal.

I went back to the previous Snort (I copied the directory before the new
install) and the problem is the same. I tried a 1.7 I have on the same
machine, same problem.

I am decidedly puzzled. (Mind you, today was one of those days. Maybe
tomorrow . . . )


-- 
Matt Whelan <matt at ...5000...>





More information about the Snort-users mailing list