[Snort-users] ACID : PHP GD error

Frank Carreiro fcarreiro at ...4629...
Fri Feb 8 10:14:13 EST 2002


You didn't compile gd support into php.  Recompile your php module with 
gd support and it should work.  From the php directory type ./configure 
--with-gd   as part of your configure options.

I myself have run into this problem and haven't had a chance to try the 
above yet.  I did find this in their troubleshooting docs (I think).

Hopefully I'll have some time today to try it also :-)

Oh.. and if you don't have the gd library loaded then you will need to 
download/install it.  I believe it comes by default in most linux 
distros (I'm running redhat 6.2 on this particular system)

Frank



>
>  Finally i was able to configure snort, mysql and ACID. When i goto
>http://localhost:443 i am able to access ACID. Everything is working fine,
>except the "Graph Alert data (EXPERIMENTAL)" link is giving an error. When i
>click on "Graph Alert Data" it gives the following error:
>  PHP ERROR: PHP build incomplete: the prerequisite GD support required to
>generate graphs was not built into PHP. Please recompile PHP with the
>necessary library (--with-gd)
>
> Here is the output form "nm /opt/apache/libexec/libphp4.so| grep -i gd"
>    # nm libphp4.so |grep gd
>400492f0 C php_gd_char
>00130570 t php_gd_error
>00130a90 t php_gd_lex
>40045008 C php_gd_lval
>40048744 C php_gd_nerrs
>400313ae d php_gd_pact
>         U php_gd_parse
>0012f4e0 T php_gd_parse
>0012f4c8 T php_gd_parse
>40031252 d php_gd_r1
>400312b8 d php_gd_r2
>400314a6 d php_gd_yycheck
>4003143e d php_gd_yytable
>
>I have "LoadModule php4_module   libexec/libphp4.so" is uncommented in
>conf/httpd.conf. Also apache log shows PHP/4.0.4pl1 configured. I am running
>on HP-UX 11.00. Apache version 1.3.19.23.
>
>Any idea why am i getting this error. Thanks
>





More information about the Snort-users mailing list