[Snort-users] Re: Snort -T failure

LogicET at ...661... LogicET at ...661...
Mon Aug 26 09:09:02 EDT 2002


I am having the same problem as you.  If you go to a directory that contains 
the snort.conf file and run snort from there, it will initialize correctly.  
When running snort from there it runs and logs correctly.  Can anyone tell us 
why and how to allow snort to run when executed from any directory?

In a message dated 8/26/2002 11:39:43 AM Eastern Daylight Time, 
snort-users-request at lists.sourceforge.net writes:


> hello,
> 
> Yesterday I wrote because I had a problem with 'unicode'. I found out that 
> I
> installed the wrong version of snortrules. Now I installed
> snort-1.8.7.tar.gz and snortrules.tar.gz following the manual Snort, MySQL,
> Redhat 7.2. 
> I tried the snort -T command again and got a new failure message: 
> 
> [root at ...274... inprog]# snort -T
> Log directory = /var/log/snort
> Initializing Network Interface eth0
> using config file /root/.snortrc
> Initializing Preprocessors!
> Initializing Plug-ins!
> Initializating Output Plugins!
> Parsing Rules file /root/.snortrc
> +++++++++++++++++++++++++++++++++++++++++++++++++++
> Initializing rule chains...
> ERROR: Unable to open rules file: /root/.snortrc or /root//root/.snortrc
> Fatal Error, Quitting.. 
> 
> I didn't found the .snortrc file on the redhat mashine. Why snort wants to
> use the .snortrc file to inizialise and not the snort.conf file? What can I
> do now to run snort?
> 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.snort.org/pipermail/snort-users/attachments/20020826/8cecb266/attachment.html>


More information about the Snort-users mailing list