[Snort-users] Helpful hint for those of you using cvs to get the latest and greatest

Phil Wood cpw at ...440...
Fri Aug 23 12:34:03 EDT 2002


Most likely this applies to linux users (it might apply to unix users in
general.  I just don't know.  No idea about M$ configure).

# Helpful Hint number 1

  cd snort
  aclocal
  autoconf
  automake
  autoheader
  ./configure # ... your applicable config options here ...

If you are on linux and do not run this, you might see something like this while
trying to run configure:

  ...
  cd ../.. && /bin/sh /snort+/missing --run automake-1.6 --foreign src/win32/Makefile
  /snort+/missing: automake-1.6: command not found
  WARNING: `automake-1.6' is needed, and you do not seem to have it handy on your
           system.  You might have modified some files without having the
           proper tools for further handling them.  Check the `README' file,
           it often tells you about the needed prerequirements for installing
           this package.  You may also peek at any GNU archive site, in case
           some other package would contain this missing `automake-1.6' program.
  make[3]: *** [Makefile.in] Error 1
  make[3]: Leaving directory `/snort+/src/win32'
  make[2]: *** [all-recursive] Error 1
  make[2]: Leaving directory `/snort+/src'
  make[1]: *** [all-recursive] Error 1
  make[1]: Leaving directory `/snort+'
  make: *** [all] Error 2

Later,

Phil Wood




More information about the Snort-users mailing list