[Snort-users] error: "mysql support is not compiled in this c opy"

Ed Kasky ed at ...3483...
Mon Aug 12 20:59:02 EDT 2002


What finally worked was to run configure with the following

--with-mysql=/usr/local/mysql

which is the root of the mysql installation and not the home of mysql.h

I then had to add the path to  libmysqlclient.so.10 as snort could locate 
it.  I did some digging around and added the  path to the library to 
ld.so.conf and then run ldconfig.  Snort was then able to locate everything 
just fine and I finally got it up and running!!!

Whew.  That was way more difficult than the last time I did it about a year 
ago.

Thanks to Rick, Steve and junaidi for the help.

Ed

At 04:16 PM Monday, 8/12/2002, you wrote -=>
>This is a problem I have noted before. I went and looked at what 
>object/header files snort was looking for and set the path to them and 
>watched the configure script find them. When I ran Snort, it gave the 
>"MySQL not compiled in" error. This was 1.8.7 on FreeBSD 4.4.
>
>I went back to 1.8.6 and it worked peachy keen.
>
>MySQL cetainly was installed normally, since I just used the FreeBSD package.
>
>I never figured out what was wrong, nor do I really care at the moment. 
>But I would like to know if anyone has figured this one out.

Ed Kasky
Los Angeles, CA
. . . . . . . .
I don't compare 'em.  I just catch 'em.
	-- Willie Mays





More information about the Snort-users mailing list