[Snort-users] error: "mysql support is not compiled in this c opy"

Moyer, Shawn SMoyer at ...5894...
Mon Aug 12 16:04:04 EDT 2002


Nope. Look at the subject line, junaidi. Somebody needs to change that
error. It really sucks, since this error pretty much never has anything to
do with the conf file. How many people f***ing misspell mysql, anyway?
Yeesh.

For starters, try piping the output of ./configure [your_flags] to less or
more, and scrolling back and looking at the results. You'll probably see
"checking for mysql... no" in there somewhere. Most likely the path to mysql
is wrong, or (and this happens), you may not have the includes for mysql
even though you have the libraries installed, and IIRC you need both. In
fact, I'm guessing from the path it's installed in that this may be the case
since I remember packages from mysql.com that used /usr/local/mysql as the
path and didn't include headers, just libs. RedHat does this sometimes, also
-- they break packages up into [package-name]-libs and [package-name]-devel,
-devel meaning they give you the headers. Nice if you don't want compilers
or headers on a box, not so nice when you need to compile stuff. 

Also when you re-run ./configure and rebuild, you may want to do a "make
clean" or "rm -f config.cache" just to make sure it cleans out the cached
results of the old options you passed to autoconf.

Short answer (too late for that, I know):

Try no flags at all and see if autoconf finds mysql on its own
Make sure you have headers *and* libs. Do a "find /usr/local/mysql -name
mysql.h"
Maybe try --with-mysql=/usr/local/mysql/include (This one's a guess. I
looked around to see if I had a box with MySQL installed with the path yours
has, and I don't, so I haven't checked this)





--shawn


> -----Original Message-----
> From: junaidi [mailto:junaidi at ...4162...]
> Sent: Monday, August 12, 2002 16:25
> To: Ed Kasky; Snort-users at lists.sourceforge.net
> Subject: Re: [Snort-users] error: "mysql support is not 
> compiled in this
> copy"
> 
> 
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> On Tuesday 13 August 2002 05:02, Ed Kasky wrote:
> > Specifics:
> > Snort - 1.8.7 (Build 128) with conf and rules in /etc/snort/
> > (daemon /usr/local/bin/snort -u snort -D -c /etc/snort/snort.conf )
> > Mysql - 3.23.51 in /usr/local/mysql/
> > RedHat 7.2, 2.4.7-10
> >
> > For some reason I am having a hell of a time getting snort 
> to start with
> > mysql configured.
> >
> > I ran ./configure --with-mysql=<path to mysql> and tried a number of
> > different paths, none of which seem to work.  I keep 
> getting the following
> > when trying to start the daemon:
> >
> > "snort: FATAL ERROR:  Check your configuration file to be 
> sure you did not
> > mis-spell "mysql".  If you did not, you will need to reconfigure and
> > recompile ensuring that  you have set the correct options 
> to the configure
> > script. Type   "./configure --help" to see options for the configure
> > script."
> >
> > What exactly is the path that it needs?  I read in one post 
> that it needs
> > the path to mysql.h, but that didn't work wither....
> >
> > Any help is greatly appreciated...
> 
> Did you define your mysql database in your snort.conf? For 
> example like this.
> 
> var $MYSQLDATABASE <host.domainname.com>
> 
> and then in your "output_database" in the snort.conf, use 
> that variable that 
> you created to point to your mysql database.
> 
> 
> 
> 
> junaidi
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.0.6 (GNU/Linux)
> Comment: For info see http://www.gnupg.org
> 
> iD8DBQE9WCfCInIYkBVpGqURAiP1AJ9GD+pzxZuOGMXrZ1qIt0wUWVxJwgCcCCtO
> kjlRyHlNjIJcWgifrpyDZGs=
> =t7eS
> -----END PGP SIGNATURE-----
> 
> 
> 
> -------------------------------------------------------
> This sf.net email is sponsored by: Dice - The leading online job board
> for high-tech professionals. Search and apply for tech jobs today!
> http://seeker.dice.com/seeker.epl?rel_code=31
> _______________________________________________
> Snort-users mailing list
> Snort-users at lists.sourceforge.net
> Go to this URL to change user options or unsubscribe:
> https://lists.sourceforge.net/lists/listinfo/snort-users
> Snort-users list archive:
> http://www.geocrawler.com/redir-sf.php3?list=snort-users
> 




More information about the Snort-users mailing list