[Snort-users] error: "mysql support is not compiled in this copy"

junaidi junaidi at ...4162...
Mon Aug 12 14:27:04 EDT 2002


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On Tuesday 13 August 2002 05:02, Ed Kasky wrote:
> Specifics:
> Snort - 1.8.7 (Build 128) with conf and rules in /etc/snort/
> (daemon /usr/local/bin/snort -u snort -D -c /etc/snort/snort.conf )
> Mysql - 3.23.51 in /usr/local/mysql/
> RedHat 7.2, 2.4.7-10
>
> For some reason I am having a hell of a time getting snort to start with
> mysql configured.
>
> I ran ./configure --with-mysql=<path to mysql> and tried a number of
> different paths, none of which seem to work.  I keep getting the following
> when trying to start the daemon:
>
> "snort: FATAL ERROR:  Check your configuration file to be sure you did not
> mis-spell "mysql".  If you did not, you will need to reconfigure and
> recompile ensuring that  you have set the correct options to the configure
> script. Type   "./configure --help" to see options for the configure
> script."
>
> What exactly is the path that it needs?  I read in one post that it needs
> the path to mysql.h, but that didn't work wither....
>
> Any help is greatly appreciated...

Did you define your mysql database in your snort.conf? For example like this.

var $MYSQLDATABASE <host.domainname.com>

and then in your "output_database" in the snort.conf, use that variable that 
you created to point to your mysql database.




junaidi
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.6 (GNU/Linux)
Comment: For info see http://www.gnupg.org

iD8DBQE9WCfCInIYkBVpGqURAiP1AJ9GD+pzxZuOGMXrZ1qIt0wUWVxJwgCcCCtO
kjlRyHlNjIJcWgifrpyDZGs=
=t7eS
-----END PGP SIGNATURE-----





More information about the Snort-users mailing list