[Snort-users] error: "mysql support is not compiled in this copy"

Ed Kasky ed at ...3483...
Mon Aug 12 14:04:01 EDT 2002


Specifics:
Snort - 1.8.7 (Build 128) with conf and rules in /etc/snort/
(daemon /usr/local/bin/snort -u snort -D -c /etc/snort/snort.conf )
Mysql - 3.23.51 in /usr/local/mysql/
RedHat 7.2, 2.4.7-10

For some reason I am having a hell of a time getting snort to start with 
mysql configured.

I ran ./configure --with-mysql=<path to mysql> and tried a number of 
different paths, none of which seem to work.  I keep getting the following 
when trying to start the daemon:

"snort: FATAL ERROR:  Check your configuration file to be sure you did not 
mis-spell "mysql".  If you did not, you will need to reconfigure and 
recompile ensuring that  you have set the correct options to the configure 
script. Type   "./configure --help" to see options for the configure script."

What exactly is the path that it needs?  I read in one post that it needs 
the path to mysql.h, but that didn't work wither....

Any help is greatly appreciated...

Ed
~~

Ed Kasky
Los Angeles, CA
. . . . . . . .
Reputation: what others are not thinking about you.





More information about the Snort-users mailing list